summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index b6f6f370f01e..0a200e68c540 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12010,9 +12010,9 @@ if test "$enable_fetch_external" != "no"; then
CURL=`which curl 2>/dev/null`
for i in wget /usr/bin/wget /usr/local/bin/wget /usr/sfw/bin/wget /opt/sfw/bin/wget /opt/local/bin/wget; do
- eval "$i --version" > /dev/null 2>&1
- ret=$?
- if test $ret -eq 0; then
+ # wget new enough?
+ $i --help 2> /dev/null | $GREP no-use-server-timestamps 2>&1 > /dev/null
+ if test $? -eq 0; then
WGET=$i
break
fi