summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in165
1 files changed, 35 insertions, 130 deletions
diff --git a/configure.in b/configure.in
index dbdf400c678c..a93c1cd54d5b 100644
--- a/configure.in
+++ b/configure.in
@@ -322,7 +322,7 @@ AC_ARG_ENABLE(static-gtk,
AC_ARG_ENABLE(layout,
[ --enable-layout Enable the compilation and use of layout dialogs
],,)
-AC_ARG_ENABLE(nss_module,
+AC_ARG_ENABLE(nss-module,
[ --disable-nss-module Whether to use the NSS module that is used for xml-security
],,enable_nss_module=yes)
AC_ARG_ENABLE(kde,
@@ -643,17 +643,8 @@ AC_ARG_WITH(system-redland,
[ --with-system-redland Use redland library already on system
],,)
AC_ARG_WITH(stlport,
-[ --with-stlport The location that STLport is installed in. The STL
- header files are assumed to be in
- stlport-home/stlport and the STLPort library in
- stlport-home/lib.
-
- Usage: --with-stlport=<absolute path to stlport home>
-
- Warning: disabling using --without-stlport or
- enabling using --with-stlport on a platform that
- defaults to the opposite will break ABI compatibility
-], WITH_STLPORT=$withval , WITH_STLPORT=auto)
+[ --with-stlport Only building --without-stlport is supported.
+], WITH_STLPORT=$withval , WITH_STLPORT=no)
AC_ARG_WITH(jdk-home,
[ --with-jdk-home if you have installed JDK 1.3 or later on your system
please supply the path here.
@@ -1388,7 +1379,7 @@ dnl ===================================================================
dnl Build options
dnl ===================================================================
-# Disable or enable libraries seamonkey, nss, hunspell, hyphen, saxon,
+# Disable or enable category-B librariets: nss, hunspell, hyphen, saxon,
# rhino, silgraphite, beanshell.
# Note that further below they may be enabled or disabled again by
@@ -1416,7 +1407,7 @@ if test "$enable_category_b" = "yes"; then
enable_coinmp="yes"
enable_category_b_fonts="yes"
- AC_MSG_RESULT([yes: allow modules, nss, hunspell, hyphen, saxon, rhino, beanshell, graphite, coinmp to be built])
+ AC_MSG_RESULT([yes: allow modules nss, hunspell, hyphen, saxon, rhino, beanshell, graphite, coinmp to be built])
else
# Disable libaries.
enable_nss_module="no"
@@ -1429,7 +1420,7 @@ else
enable_coinmp="no"
enable_category_b_fonts="no"
- AC_MSG_RESULT([no: disabled modules, nss, hunspell, hyphen, saxon, rhino, beanshell, graphite, coinmp])
+ AC_MSG_RESULT([no: disabled modules nss, hunspell, hyphen, saxon, rhino, beanshell, graphite, coinmp])
fi
AC_SUBST(ENABLE_CATEGORY_B)
@@ -2417,7 +2408,7 @@ dnl ===================================================================
dnl Set the gcc/gxx include directories
dnl ===================================================================
# Removed the special FreeBSD treatment. The problem was that with_gxx_include_path
-# often contains an i386 which is expanded as a macro. Solved in stlport.
+# often contains an i386 which is expanded as a macro.
if test "$GXX" = "yes"; then
AC_MSG_CHECKING([for g++ include path])
if test -z "$with_gxx_include_path"; then
@@ -2704,115 +2695,12 @@ dnl Checks for what the default STL should be
dnl ===================================================================
AC_MSG_CHECKING([what the default STL should be])
DEFAULT_TO_STLPORT="no"
- if test "$_os" = "Linux"; then
- case "$build_cpu" in
- i?86)
- case "$build_os" in k*bsd*-gnu*)
- DEFAULT_TO_STLPORT="no"
- ;;
- *)
- DEFAULT_TO_STLPORT="yes"
- ;;
- esac
- ;;
- *)
- DEFAULT_TO_STLPORT="no"
- ;;
- esac
- elif test "$_os" = "SunOS"; then
- DEFAULT_TO_STLPORT="yes"
- elif test "$_os" = "WINNT" -a "$WITH_MINGWIN" != "yes"; then
- DEFAULT_TO_STLPORT="yes"
- elif test "$_os" = "OS2"; then
- DEFAULT_TO_STLPORT="yes"
- elif test "$_os" = "FreeBSD"; then
- DEFAULT_TO_STLPORT="yes"
- fi
- if test "$DEFAULT_TO_STLPORT" = "yes"; then
- AC_MSG_RESULT([stlport])
- else
- AC_MSG_RESULT([system])
- fi
- if test "$WITH_STLPORT" = "auto"; then
- WITH_STLPORT=$DEFAULT_TO_STLPORT
- fi
-
-dnl ===================================================================
-dnl Checks for STLPORT
-dnl ===================================================================
- AC_MSG_CHECKING([for STL providing headers])
- STLPORT4=""
- USE_SYSTEM_STL=""
- if test "$WITH_STLPORT" = "yes"; then
- AC_MSG_RESULT([using internal stlport.])
- if test "$DEFAULT_TO_STLPORT" != "yes"; then
- AC_MSG_WARN([using stlport. Warning, breaks your ABI compatibility!])
- echo "using stlport. Warning: breaks your ABI compatibility!" >>warn
- fi
- elif test "$WITH_STLPORT" = "no"; then
- AC_MSG_RESULT([using system STL])
- USE_SYSTEM_STL="YES"
- if test "$DEFAULT_TO_STLPORT" != "no"; then
- AC_MSG_WARN([using system STL. Warning, breaks your ABI compatibility!])
- echo "using system STL. Warning: breaks your ABI compatibility!" >>warn
- fi
- else
- STLPORT4=$WITH_STLPORT
- if test "$_os" != "WINNT" -o "$WITH_MINGWIN" = "yes"; then
- AC_TRY_CPP($STLPORT4/stlport/hash_map, AC_MSG_RESULT([checked.]), AC_MSG_ERROR([STLport headers not found.]))
- else
- dnl AC_TRY_CPP doesn't work for MSVC because C++ preprocessor is not found by autoconf.
- if test -f "$STLPORT4/stlport/hash_map"; then
- AC_MSG_RESULT([checked.])
- else
- AC_MSG_ERROR([STLport headers not found.])
- fi
- fi
- if test "$_os" != "WINNT" -o "$WITH_MINGWIN" = "yes"; then
- AC_MSG_CHECKING([for STLport libraries])
- if test "$_os" = "SunOS"; then
- if test -f "$STLPORT4/lib/libstlport_sunpro.so"; then
- AC_MSG_RESULT([checked])
- elif test -f "$STLPORT4/lib/libstlport.so"; then
- AC_MSG_RESULT([checked])
- STLPORT_VER=500
- else
- AC_MSG_ERROR([STLport libraries not found])
- fi
- elif test "$_os" = "Darwin"; then
- if test -f "$STLPORT4/lib/libstlport_gcc.dylib"; then
- AC_MSG_RESULT([checked])
- elif test -f "$STLPORT4/lib/libstlport.dylib"; then
- AC_MSG_RESULT([checked])
- STLPORT_VER=500
- else
- AC_MSG_ERROR([STLport libraries not found])
- fi
- else
- if test -f "$STLPORT4/lib/libstlport_gcc.so"; then
- AC_MSG_RESULT([checked])
- elif test -f "$STLPORT4/lib/libstlport.so"; then
- AC_MSG_RESULT([checked])
- STLPORT_VER=500
- else
- AC_MSG_ERROR([STLport libraries not found])
- fi
- fi
- fi
- if test "$DEFAULT_TO_STLPORT" != "yes"; then
- AC_MSG_WARN([using stlport. Warning: breaks your ABI compatibility!])
- echo "using stlport. Warning: breaks your ABI compatibility!" >>warn
- fi
- fi
-
-if test -z "$STLPORT4"; then
- STLPORT4="NO_STLPORT4"
-fi
-if test -z "$STLPORT_VER"; then
- STLPORT_VER=400
+if test "$WITH_STLPORT" != "no"; then
+ AC_MSG_ERROR([Option --with-stlport is no longer available.])
+else
+ USE_SYSTEM_STL="YES"
fi
-AC_SUBST(STLPORT4)
-AC_SUBST(STLPORT_VER)
+
AC_SUBST(USE_SYSTEM_STL)
dnl ===================================================================
@@ -2883,6 +2771,7 @@ fi
dnl ===================================================================
dnl system stl sanity tests
dnl ===================================================================
+if false ; then # TODO: update TR1 compliant STLs
if test "$USE_SYSTEM_STL" = "YES"; then
AC_MSG_CHECKING([system stl sanity])
AC_LANG_PUSH([C++])
@@ -2958,6 +2847,7 @@ _ACEOF
AC_LANG_POP([C++])
fi
+fi # endof TODO: update TR1 compliant STLs
AC_SUBST(HAVE_GCC_VISIBILITY_FEATURE)
@@ -4048,15 +3938,27 @@ if test "$_os" = "Darwin" && test "$with_system_python" != "no"; then
with_system_python=yes
_python="/Library/Frameworks/Python.framework/Versions/Current/bin/python"
+ if test ! -f $_python; then
+ _python="/usr/bin/python"
+ fi
+ AC_MSG_RESULT([compiling against system python ($_python)])
+
_python_hexversion=`$_python -c "import sys; print(sys.hexversion);"`
-
+
dnl hex version of Python 2.7.1 = 34013680
if test $_python_hexversion -ge 34013680 ; then
+ _python_version=`$_python -c "import sys; print sys.version;" | head -n 1`
AC_MSG_RESULT([compiling against system python (version $_python_version)])
_python_ver=`$_python -c "import distutils.sysconfig; print(distutils.sysconfig.get_config_var('VERSION'));"`
- PYTHON_CFLAGS="-I/Library/Frameworks/Python.framework/Versions/$_python_ver/include/python$_python_ver"
+ if test -d "/Library/Frameworks/Python.framework/Versions/$_python_ver/include/python$_python_ver"; then
+ PYTHON_CFLAGS="-I/Library/Frameworks/Python.framework/Versions/$_python_ver/include/python$_python_ver"
+ elif test -d "/Developer/SDKs/MacOSX10.4u.sdk/Library/Frameworks/Python.framework/Versions/$_python_ver/include/python$_python_ver"; then
+ PYTHON_CFLAGS="-I/Developer/SDKs/MacOSX10.4u.sdk/Library/Frameworks/Python.framework/Versions/$_python_ver/include/python$_python_ver"
+ else
+ PYTHON_CFLAGS="-I/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.7.sdk/System/Library/Frameworks/Python.framework/Versions/$_python_ver/include/python$_python_ver"
+ fi
else
AC_MSG_ERROR([Python 2.7.1 or higher is required])
fi
@@ -4774,7 +4676,7 @@ fi
AC_SUBST(WITH_LDAP)
AC_SUBST(WITH_OPENLDAP)
-AC_MSG_CHECKING([whether to build provided NSS module])
+AC_MSG_CHECKING([whether to build the internal NSS module])
if test "$enable_nss_module" != "no"; then
ENABLE_NSS_MODULE="YES"
BUILD_TYPE="$BUILD_TYPE NSS"
@@ -4782,9 +4684,12 @@ if test "$enable_nss_module" != "no"; then
if test "$_os" = "WINNT"; then
AC_MSG_CHECKING([for Mozilla build tooling])
if test -z "$MOZILLABUILD" ; then
-AC_MSG_ERROR([Mozilla build tooling not found. It is needed for NSS.
-Use the --with-mozilla-build option after installling the tools obtained
-from http://ftp.mozilla.org/pub/mozilla.org/mozilla/libraries/win32])
+AC_MSG_ERROR([
+Mozilla build tooling not found!
+ It is required for NSS that is needed for AOO's security facilities.
+ Either disable NSS using the option --disable-nss-module
+ or use the --with-mozilla-build option after installing the tool obtained
+ from http://ftp.mozilla.org/pub/mozilla.org/mozilla/libraries/win32])
else
if test \( "$WITH_MINGWIN" = "yes" \) ; then
if test ! -d "$MOZILLABUILD" ; then