summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in30
1 files changed, 15 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index d7681d62bd4d..914e8cf47bd8 100644
--- a/configure.in
+++ b/configure.in
@@ -393,8 +393,8 @@ AC_ARG_ENABLE(database-connectivity,
[Disable various database connectivity. Work in progress, use only if you are hacking on it.])
)
-AC_ARG_ENABLE(interpreters,
- AS_HELP_STRING([--disable-interpreters],
+AC_ARG_ENABLE(scripting,
+ AS_HELP_STRING([--disable-scripting],
[Disable BASIC, Java and Python. Work in progress, use only if you are hacking on it.])
)
@@ -2042,21 +2042,21 @@ else
fi
AC_SUBST(DISABLE_DBCONNECTIVITY)
-if test -z "$enable_interpreters"; then
- # Disable interpreters for iOS unless specifically overridden
- # with --enable-interpreters.
+if test -z "$enable_scripting"; then
+ # Disable scripting for iOS unless specifically overridden
+ # with --enable-scripting.
if test $_os != iOS; then
- enable_interpreters=yes
+ enable_scripting=yes
fi
fi
-DISABLE_INTERPRETERS=''
-if test "$enable_interpreters" = yes; then
- BUILD_TYPE="$BUILD_TYPE INTERPRETERS"
+DISABLE_SCRIPTING=''
+if test "$enable_scripting" = yes; then
+ BUILD_TYPE="$BUILD_TYPE SCRIPTING"
else
- DISABLE_INTERPRETERS='TRUE'
+ DISABLE_SCRIPTING='TRUE'
fi
-AC_SUBST(DISABLE_INTERPRETERS)
+AC_SUBST(DISABLE_SCRIPTING)
dnl ===================================================================
dnl Extra check for Windows. Cygwin builds need gcc to build dmake
@@ -4535,8 +4535,8 @@ dnl Java support enable
dnl ===================================================================
AC_MSG_CHECKING([whether to build with Java support])
if test "$with_java" != "no"; then
- if test "$DISABLE_INTERPRETERS" = TRUE; then
- AC_MSG_RESULT([no, overridden by --disable-interpreters])
+ if test "$DISABLE_SCRIPTING" = TRUE; then
+ AC_MSG_RESULT([no, overridden by --disable-scripting])
SOLAR_JAVA=""
else
AC_MSG_RESULT([yes])
@@ -5953,8 +5953,8 @@ no|disable)
DISABLE_PYTHON=TRUE
;;
""|yes|auto)
- if test "$DISABLE_INTERPRETERS" = TRUE; then
- AC_MSG_RESULT([no, overridden by --disable-interpreters])
+ if test "$DISABLE_SCRIPTING" = TRUE; then
+ AC_MSG_RESULT([no, overridden by --disable-scripting])
enable_python=no
DISABLE_PYTHON=TRUE
elif test $build_os = cygwin; then