summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 44bb5e9a1b66..39c533d66c27 100644
--- a/configure.in
+++ b/configure.in
@@ -5389,8 +5389,10 @@ dnl ===================================================================
dnl Check for PostgreSQL stuff
dnl ===================================================================
-if test "x$enable_ext_postgresql_sdbc" = "xyes" -a "x$enable_extension_integration" != "xno"; then
- SCPDEFS="$SCPDEFS -DWITH_EXTENSION_POSTGRESQL"
+if test "x$enable_ext_postgresql_sdbc" = "xyes"; then
+ if test "x$enable_extension_integration" = "xyes"; then
+ SCPDEFS="$SCPDEFS -DWITH_EXTENSION_POSTGRESQL"
+ fi
AC_MSG_CHECKING([PostgreSQL C interface])
if test "$with_system_postgresql" = "yes"; then