summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9cd71ede0544..1c9a08d965fd 100644
--- a/configure.in
+++ b/configure.in
@@ -6790,6 +6790,7 @@ dnl ***************************************
dnl Checking for bison and flex
dnl ***************************************
AC_PATH_PROG(BISON, bison)
+ANCIENT_BISON="NO"
if test -z "$BISON"; then
AC_MSG_ERROR([no bison found in \$PATH, install it])
else
@@ -6807,7 +6808,12 @@ else
else
AC_MSG_ERROR([failed ($BISON $_bison_version need 1.875+ (or 1.75 and older))])
fi
+ if test "$_bison_longver" -lt 2000; then
+ ANCIENT_BISON="YES"
+ fi
fi
+AC_SUBST(ANCIENT_BISON)
+
AC_PATH_PROG(FLEX, flex)
if test -z "$FLEX"; then
AC_MSG_ERROR([no flex found in \$PATH, install it])