summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 5c2ba1cbf3c5..14273cb4d2eb 100644
--- a/configure.in
+++ b/configure.in
@@ -3728,7 +3728,8 @@ if test "$_os" = "Darwin" && test "$with_system_python" != "no"; then
AC_MSG_RESULT([compiling against MacOSX10.4u.sdk (python version 2.3)])
PYTHON_CFLAGS="-I/Developer/SDKs/MacOSX10.4u.sdk/System/Library/Frameworks/Python.framework/Versions/2.3/include/python2.3"
PYTHON_LIBS="-framework Python"
-elif test "$with_system_python" != "no" -o -n "$with_system_libs"; then
+elif test -n "$with_system_python" -o -n "$with_system_libs" && \
+ test "$with_system_python" != "no"; then
with_system_python=yes
AC_MSG_RESULT([external])
AM_PATH_PYTHON([2.2])