summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in288
1 files changed, 93 insertions, 195 deletions
diff --git a/configure.in b/configure.in
index 3505be436cf6..0ce538aeed8e 100644
--- a/configure.in
+++ b/configure.in
@@ -115,10 +115,6 @@ AC_ARG_ENABLE(qadevooo,
[ --disable-qadevooo OO.o includes some qa testsuites which some
packagers may wish to build without
],,enable_qadevooo="yes")
-AC_ARG_ENABLE(fontooo,
-[ --disable-fontooo disable FontOOo
- (useful for distributions using fontconfig for OOo)
-],,enable_fontooo="yes")
AC_ARG_ENABLE(mathmldtd,
[ --disable-mathmldtd disable mathmldtd
(useful for distributions that want to avoid packaging
@@ -131,9 +127,6 @@ AC_ARG_ENABLE(evolution2,
AC_ARG_WITH(system-stdlibs,
[ --with-system-stdlibs use libstdc++/libgcc_s already on system
],,checkforstdlibproblems=yes)
-AC_ARG_WITH(system-mspack,
-[ --with-system-mspack use libmspack already installed on system
-],,)
AC_ARG_ENABLE(cups,
[ --disable-cups disable cups support in the psprint project
],,enable_cups=yes)
@@ -786,12 +779,6 @@ AC_ARG_WITH(build-version,
Usage: --with-build-version="Built by Jim"
],with_build_version=$withval)
-AC_ARG_ENABLE(sgistl,
-[ --enable-sgistl for IRIX users, use this option option to build
- OpenOffice.org using SGI's STL.
-
- Usage: --enable-sgistl=yes
-],,)
AC_ARG_WITH(alloc,
[ --with-alloc Define which allocator to build with
(choices are oo, system, tcmalloc)
@@ -939,9 +926,6 @@ case "$build_os" in
test_cups=yes
test_randr=yes
test_freetype=yes
- if getconf GNU_LIBPTHREAD_VERSION |grep -q NPTL; then
- PTHREAD_CFLAGS="-DNPTL"
- fi
_os=Linux
;;
gnu)
@@ -1021,12 +1005,6 @@ case "$build_os" in
PTHREAD_LIBS="-pthread -lpthread"
_os=NetBSD
;;
- irix*)
- test_cups=no
- test_randr=no
- test_freetype=yes
- _os=IRIX
- ;;
aix*)
test_cups=no
test_randr=no
@@ -1451,7 +1429,8 @@ if test "$COMPATH" = "." ; then
dnl double square bracket to get single because of M4 quote...
COMPATH=`echo $COMPATH | $SED "s@/[[^/:]]*\\\$@@"`;
fi
-
+COMPATH=`echo $COMPATH | $SED "s@/[[Bb]][[Ii]][[Nn]]\\\$@@"`;
+echo $COMPATH
dnl ===================================================================
dnl Test the gcc version, 3 is OK
dnl ===================================================================
@@ -1595,7 +1574,7 @@ dnl ===================================================================
if test "$_os" = "SunOS"; then
if test "$CC" = "cc"; then
AC_PATH_PROGS(_cc, cc)
- COMPATH=`echo $_cc | $SED -n "s/\/cc//p"`
+ COMPATH=`echo $_cc | $SED -n "s/\/bin\/cc//p"`
AC_MSG_CHECKING([the SunStudio C/C++ compiler version])
dnl cc -V outputs to standard error!!!!
_sunstudio_string=`$CC -V 2>&1 | grep '^cc' | sed -e 's/.* C //'`
@@ -1634,37 +1613,12 @@ fi
AC_SUBST(HAVE_LD_HASH_STYLE)
dnl ===================================================================
-dnl Test the IRIX SGI Mips pro compiler
-dnl ===================================================================
-if test "$_os" = "IRIX" -o "$_os" = "IRIX64"; then
- if test "$CC" = "cc"; then
- AC_PATH_PROGS(_cc, cc)
- COMPATH=`echo $_cc | $SED -n "s/\/cc//p"`
- AC_MSG_CHECKING([the SGI MIPSpro C compiler version])
- dnl cc -version outputs to standard error!!!!
- _mipspro_version=`$CC -version 2>&1 | $AWK '{ print $4 }'`
- _mipspro_major=`echo $_mipspro_version | $AWK -F. '{ print $1 }'`
- if test "$_mipspro_major" != "7"; then
- AC_MSG_ERROR([found version "$_mipspro_version", use version 7.2+ of the SGI MIPSpro C compiler])
- else
- _mipspro_minor=`echo $_mipspro_version | $AWK -F. '{ if ($2 <= 1) print "false"; else print "true" }'`
- if test "$_mipspro_minor" = "false"; then
- AC_MSG_ERROR([found version "$_mipspro_version", use version 7.2+ of the SGI MIPSpro C compiler])
- else
- dnl compiler will do
- AC_MSG_RESULT([checked])
- fi
- fi
- fi
-fi
-
-dnl ===================================================================
dnl Test the Compaq compiler for OSF1
dnl ===================================================================
if test "$_os" = "OSF1"; then
if test "$CC" = "cc"; then
AC_PATH_PROGS(_cc, cc)
- COMPATH=`echo $_cc | $SED -n "s/\/cc//p"`
+ COMPATH=`echo $_cc | $SED -n "s/\/bin\/cc//p"`
AC_MSG_WARN([******* $_cc , $COMPATH])
AC_MSG_CHECKING([the Compaq C compiler version])
dnl cc -V outputs to standard error!!!!
@@ -1790,8 +1744,8 @@ if test "$_os" = "WINNT"; then
CC=`cygpath -u "$CC"`
# Remove /cl.exe from CC case insensitive
AC_MSG_RESULT([found ($CC)])
- COMPATH=`echo $CC | $SED 's@/[[cC]][[lL]]\.[[eE]][[xX]][[eE]]@@'`
- export INCLUDE=`cygpath -d "$COMPATH/../Include"`
+ COMPATH=`echo $CC | $SED 's@\/[[Bb]][[Ii]][[Nn]]\/[[cC]][[lL]]\.[[eE]][[xX]][[eE]]@@'`
+ export INCLUDE=`cygpath -d "$COMPATH/Include"`
dnl Check which Microsoft C/C++ compiler is found
AC_MSG_CHECKING([the Version of Microsoft C/C++ Compiler])
dnl The following find microsoft, matches nn.nn.nnnn then pulls numbers out.
@@ -2220,7 +2174,7 @@ _ACEOF
if test -e "$MINGW_CLIB_DIR/libgcc_s.a"; then
AC_MSG_CHECKING([dynamic libgcc name])
MINGW_GCCDLL_pattern=`nm $MINGW_CLIB_DIR/libgcc_s.a | sed -ne 's@.* _libgcc\(.*\)_dll_iname@libgcc\1.dll@p' | uniq | sed -e 's@_@?@g'`
- MINGW_GCCDLL=`cd $COMPATH && ls $MINGW_GCCDLL_pattern 2>/dev/null`
+ MINGW_GCCDLL=`cd $COMPATH/bin && ls $MINGW_GCCDLL_pattern 2>/dev/null`
if test -n "$MINGW_GCCDLL"; then
MINGW_SHARED_GCCLIB=YES
AC_MSG_RESULT([use $MINGW_GCCDLL])
@@ -2237,7 +2191,7 @@ _ACEOF
if test -e "$MINGW_CLIB_DIR/libstdc++_s.a" ; then
AC_MSG_CHECKING([dynamic libstdc++ name])
MINGW_GXXDLL_pattern=`nm $MINGW_CLIB_DIR/libstdc++_s.a | sed -ne 's@.* _libstdc__\(.*\)_dll_iname@libstdc++\1.dll@p' | uniq | sed -e 's@_@?@g'`
- MINGW_GXXDLL=`cd $COMPATH && ls $MINGW_GXXDLL_pattern 2>/dev/null`
+ MINGW_GXXDLL=`cd $COMPATH/bin && ls $MINGW_GXXDLL_pattern 2>/dev/null`
if test -n "$MINGW_GXXDLL"; then
MINGW_SHARED_GXXLIB=YES
AC_MSG_RESULT([use $MINGW_GXXDLL])
@@ -2287,21 +2241,6 @@ if test "$_os" = "Darwin"; then
fi
fi
dnl ===================================================================
-dnl Extra checking for the IRIX compiler
-dnl ===================================================================
-if test "$_os" = "IRIX" -o "$_os" = "IRIX64"; then
- dnl MIPSpro C++ compiler packaged with MIPSpro C compiler
- if test "$CC" = "cc"; then
- AC_MSG_CHECKING([SGI MIPSpro C++ Compiler])
- if test "$CXX" != "CC"; then
- AC_MSG_WARN([SGI MIPSpro C++ was not found])
- echo "SGI MIPSpro C++ was not found" >> warn
- else
- AC_MSG_RESULT([checked])
- fi
- fi
-fi
-dnl ===================================================================
dnl Extra checking for the OSF compiler
dnl ===================================================================
if test "$_os" = "OSF1"; then
@@ -2443,23 +2382,6 @@ if test "$_os" = "SunOS"; then
fi
dnl ===================================================================
-dnl Checks for SGI STL
-dnl ===================================================================
-if test -n "$enable_sgistl" && "$enable_sgistl" != "no"; then
- if test "$_os" = "IRIX" -o "$_os" = "IRIX64"; then
- AC_MSG_CHECKING([for SGI STL])
- if test -d /usr/include/CC ; then
- AC_MSG_RESULT([yes.])
-
- else
- AC_MSG_RESULT([not found.])
- fi
- else
- AC_MSG_ERROR([Option --enable-sgistl is only valid for IRIX])
- fi
-else
-
-dnl ===================================================================
dnl Checks for what the default STL should be
dnl ===================================================================
AC_MSG_CHECKING([what the default STL should be])
@@ -2542,19 +2464,6 @@ dnl ===================================================================
else
AC_MSG_ERROR([STLport libraries not found])
fi
- elif test "$_os" = "IRIX" -o "$_os" = "IRIX64"; then
- if test -f "$STLPORT4/lib/libstlport_mipspro_41.so"; then
- AC_MSG_RESULT([checked])
- else
- if test -f "$STLPORT4/lib/libstlport_gcc.so"; then
- AC_MSG_RESULT([checked])
- elif test -f "$STLPORT4/lib/libstlport.so"; then
- AC_MSG_RESULT([checked])
- STLPORT_VER=500
- else
- AC_MSG_ERROR([STLport libraries not found])
- fi
- fi
else
if test -f "$STLPORT4/lib/libstlport_gcc.so"; then
AC_MSG_RESULT([checked])
@@ -2571,7 +2480,6 @@ dnl ===================================================================
echo "using stlport. Warning, breaks your ABI compatability!" >>warn
fi
fi
-fi
if test -z "$STLPORT4"; then
STLPORT4="NO_STLPORT4"
@@ -2712,11 +2620,18 @@ _ACEOF
if ! $CXX $CXXFLAGS $CPPFLAGS -fpic -S visibility.cxx 2>/dev/null > /dev/null; then
gccvisbroken=yes
else
- if $EGREP -q '@PLT|\$stub|\(PLT\)' visibility.s; then
- gccvisbroken=no;
- else
- gccvisbroken=yes;
- fi
+ case "$build_cpu" in
+ i?86|x86_64)
+ if $EGREP -q '@PLT' visibility.s; then
+ gccvisbroken=no
+ else
+ gccvisbroken=yes
+ fi
+ ;;
+ *)
+ gccvisbroken=no
+ ;;
+ esac
fi
rm -f visibility.s
@@ -2977,7 +2892,7 @@ if test "$SOLAR_JAVA" != ""; then
AC_MSG_RESULT([checked (ecj)])
#TODO: what's to do here? some switch to do 1.5 compiling?
JAVAFLAGS="-source 1.5 -target 1.5"
- _gij_longver="50000"
+ _gij_longver="40200"
fi
fi
@@ -3032,7 +2947,7 @@ fi
if test "$SOLAR_JAVA" != ""; then
dnl first check if we have been asked to autodetect JAVA_HOME with a recent gij
if test "$JDK" == "gcj" -a -z "$JAVA_HOME"; then
- if test "x$with_jdk_home" = "x" -a "$_gij_longver" -ge "50000"; then
+ if test "x$with_jdk_home" = "x" -a "$_gij_longver" -ge "40200"; then
cat > findhome.java <<_ACEOF
[import java.io.File;
@@ -3072,7 +2987,7 @@ _ACEOF
fi
dnl second sanity check JAVA_HOME if possible
- if test "$JDK" != "gcj" -o "$_gij_longver" -ge "50000"; then
+ if test "$JDK" != "gcj" -o "$_gij_longver" -ge "40200"; then
# check if JAVA_HOME was (maybe incorrectly?) set automatically to /usr
if test "$JAVA_HOME" = "/usr" -a "x$with_jdk_home" = "x"; then
@@ -3350,9 +3265,6 @@ if test "$_os" != "WINNT" -a \( "z$enable_epm" = "z" -o "$enable_epm" != "no" \)
OSF1)
PKGFORMAT=setld
;;
- IRIX)
- PKGFORMAT=tardist
- ;;
# we never should get here since we check the arciecture/os at the beginning,
# but go sure...
*)
@@ -3852,25 +3764,14 @@ if test -n "$with_system_db" -o -n "$with_system_libs" && \
], []
)
AC_MSG_CHECKING([whether db is at least 4.1])
- for v in `seq 1 7`; do
- AC_TRY_RUN([
+ AC_TRY_RUN([
#include <db.h>
int main(int argc, char **argv) {
- if(DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR == $v) return 0;
+ if(DB_VERSION_MAJOR > 4 || (DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1)) return 0;
else return 1;
}
- ], [DB_VERSION_MINOR=$v], [])
- done
- if test "$DB_VERSION_MINOR" -gt "1"; then
- AC_MSG_RESULT([OK])
- DB_VERSION=4.$DB_VERSION_MINOR
- else
- AC_MSG_ERROR([no. you need at least db 4.1])
- fi
- # does not work :/
- #AC_CHECK_LIB(db, db_create, [],
- # [AC_MSG_ERROR([db library not installed or functional])], [])
+ ], [AC_MSG_RESULT([yes])], [AC_MSG_ERROR([no. you need at least db 4.1])])
AC_HAVE_LIBRARY(db, [],
[AC_MSG_ERROR([db not installed or functional])], [])
SCPDEFS="$SCPDEFS -DSYSTEM_DB"
@@ -4689,7 +4590,8 @@ if test "$_os" != "WINNT" -a "$_os" != "OS2" -a "$_os" != "Darwin"; then
[#include <X11/Intrinsic.h>])
else
AC_MSG_RESULT([yes])
- AC_CHECK_HEADERS(X11/Xaw/Label.h,[],[AC_MSG_ERROR([Xaw include headers not found])])
+ AC_CHECK_HEADERS(X11/Xaw/Label.h,[],[AC_MSG_ERROR([Xaw include headers not found])],
+ [#include <X11/Intrinsic.h>])
AC_CHECK_LIB(Xaw, main, [],
[AC_MSG_ERROR(Xaw library not found or functional)], [])
fi
@@ -5418,8 +5320,8 @@ if test "$_os" = "WINNT"; then
if test -x ./external/msi/instmsia.exe -a -x ./external/msi/instmsiw.exe; then
AC_MSG_RESULT([found])
else
- MSIAPATH=`/bin/find "$COMPATH/../.." -iname instmsia.exe | head -n 1`
- MSIWPATH=`/bin/find "$COMPATH/../.." -iname instmsiw.exe | head -n 1`
+ MSIAPATH=`/bin/find "$COMPATH/.." -iname instmsia.exe | head -n 1`
+ MSIWPATH=`/bin/find "$COMPATH/.." -iname instmsiw.exe | head -n 1`
if test -n "$MSIAPATH" -a -n "$MSIWPATH"; then
cp "$MSIAPATH" ./external/msi/ && chmod +x ./external/msi/instmsia.exe && MSIACOPY="OK"
cp "$MSIWPATH" ./external/msi/ && chmod +x ./external/msi/instmsiw.exe && MSIWCOPY="OK"
@@ -5936,37 +5838,74 @@ AC_SUBST(LIBSERIALIZER_JAR)
if test "$ENABLE_MEDIAWIKI" = "YES" -o "$ENABLE_REPORTBUILDER" = "YES"; then
AC_MSG_CHECKING([which Apache commons-* libs to use])
if test "$with_system_apache_commons" = "yes"; then
- SYSTEM_APACHE_COMMONS=YES
- AC_MSG_RESULT([external])
+ SYSTEM_APACHE_COMMONS=YES
+ AC_MSG_RESULT([external])
if test "$ENABLE_MEDIAWIKI" = "YES"; then
- if test -z "$COMMONS_CODEC_JAR"; then
- COMMONS_CODEC_JAR=/usr/share/java/commons-codec-1.3.jar
- fi
- AC_CHECK_FILE($COMMONS_CODEC_JAR, [],
- [AC_MSG_ERROR(commons-codec.jar not found.)], [])
- if test -z "$COMMONS_LANG_JAR"; then
- COMMONS_LANG_JAR=/usr/share/java/commons-lang-2.3.jar
- fi
- AC_CHECK_FILE($COMMONS_LANG_JAR, [],
- [AC_MSG_ERROR(commons-lang.jar not found.)], [])
- if test -z "$COMMONS_HTTPCLIENT_JAR"; then
- COMMONS_HTTPCLIENT_JAR=/usr/share/java/commons-httpclient-3.1.jar
- fi
- AC_CHECK_FILE($COMMONS_HTTPCLIENT_JAR, [],
- [AC_MSG_ERROR(commons-httpclient.jar not found.)], [])
+ if test -z $COMMONS_CODEC_JAR; then
+ AC_CHECK_FILE(/usr/share/java/commons-codec-1.3.jar,
+ [ COMMONS_CODEC_JAR=/usr/share/java/commons-codec-1.3.jar ],
+ [
+ AC_CHECK_FILE(/usr/share/java/commons-codec.jar,
+ [ COMMONS_CODEC_JAR=/usr/share/java/commons-codecs.jar ],
+ [AC_MSG_ERROR(commons-codec.jar replacement not found.)]
+ )
+ ]
+ )
+ else
+ AC_CHECK_FILE($COMMONS_CODEC_JAR, [],
+ [AC_MSG_ERROR(commons-codec.jar not found.)], [])
+ fi
+
+ if test -z $COMMONS_LANG_JAR; then
+ AC_CHECK_FILE(/usr/share/java/commons-lang-2.3.jar,
+ [ COMMONS_LANG_JAR=/usr/share/java/commons-lang-2.3.jar ],
+ [
+ AC_CHECK_FILE(/usr/share/java/commons-lang.jar,
+ [ COMMONS_LANG_JAR=/usr/share/java/commons-lang.jar ],
+ [AC_MSG_ERROR(commons-lang.jar replacement not found.)]
+ )
+ ]
+ )
+ else
+ AC_CHECK_FILE($COMMONS_LANG_JAR, [],
+ [AC_MSG_ERROR(commons-lang.jar not found.)], [])
+ fi
+
+ if test -z $COMMONS_HTTPCLIENT_JAR; then
+ AC_CHECK_FILE(/usr/share/java/commons-httpclient-3.1.jar,
+ [ COMMONS_HTTPCLIENT_JAR=/usr/share/java/commons-httpclient-3.1.jar ],
+ [
+ AC_CHECK_FILE(/usr/share/java/commons-httpclient.jar,
+ [ COMMONS_HTTPCLIENT_JAR=/usr/share/java/commons-httpclient.jar ],
+ [AC_MSG_ERROR(commons-httpclient.jar replacement not found.)]
+ )
+ ]
+ )
+ else
+ AC_CHECK_FILE($COMMONS_HTTPCLIENT_JAR, [],
+ [AC_MSG_ERROR(commons-httpclient.jar not found.)], [])
+ fi
fi
if test "$ENABLE_MEDIAWIKI" = "YES" -o "$ENABLE_REPORTBUILDER" = "YES"; then
- if test -z "$COMMONS_LOGGING_JAR"; then
- COMMONS_LOGGING_JAR=/usr/share/java/commons-logging-1.1.1.jar
- fi
- AC_CHECK_FILE($COMMONS_LOGGING_JAR, [],
- [AC_MSG_ERROR(commons-logging.jar not found.)], [])
-
+ if test -z $COMMONS_LOGGING_JAR; then
+ AC_CHECK_FILE(/usr/share/java/commons-logging-1.1.1.jar,
+ [ COMMONS_LOGGING_JAR=/usr/share/java/commons-logging-1.1.1.jar ],
+ [
+ AC_CHECK_FILE(/usr/share/java/commons-logging.jar,
+ [ COMMONS_LOGGING_JAR=/usr/share/java/commons-logging.jar ],
+ [AC_MSG_ERROR(commons-logging.jar replacement not found.)]
+ )
+ ]
+ )
+ else
+ AC_CHECK_FILE($COMMONS_LOGGING_JAR, [],
+ [AC_MSG_ERROR(commons-logging.jar not found.)], [])
+ fi
fi
else
- AC_MSG_RESULT([internal])
- SYSTEM_APACHE_COMMONS=NO
- BUILD_TYPE="$BUILD_TYPE APACHE_COMMONS TOMCAT"
+ AC_MSG_RESULT([internal])
+ SYSTEM_APACHE_COMMONS=NO
+ BUILD_TYPE="$BUILD_TYPE APACHE_COMMONS TOMCAT"
fi
fi
AC_SUBST(SYSTEM_APACHE_COMMONS)
@@ -6258,47 +6197,6 @@ fi
AC_SUBST(ENABLE_KAB)
dnl ===================================================================
-dnl Test whether to include FontOOo
-dnl ===================================================================
-AC_MSG_CHECKING([whether to include FontOOo])
-if test -n "$enable_fontooo"; then
- if test "$enable_fontooo" = "no"; then
- AC_MSG_RESULT([no])
- WITH_FONTOOO=NO
- SCPDEFS="$SCPDEFS -DWITHOUT_FONTOOO"
- else
- AC_MSG_RESULT([yes])
- WITH_FONTOOO=YES
- BUILD_TYPE="$BUILD_TYPE MSFONTEXTRACT"
- fi
-else
- AC_MSG_RESULT([no])
- WITH_FONTOOO=NO
- SCPDEFS="$SCPDEFS -DWITHOUT_FONTOOO"
-fi
-AC_SUBST(WITH_FONTOOO)
-
-if test "$WITH_FONTOOO" = "YES"; then
- dnl ===============================================================
- dnl Check whether to use libmspack from system
- dnl ===============================================================
- AC_MSG_CHECKING([whether to use system libmspack])
- if test -n "$with_system_mspack" -o -n "$with_system_libs" && \
- test "$with_system_mspack" != "no"; then
- AC_MSG_RESULT([yes])
- SYSTEM_MSPACK=YES
- AC_CHECK_HEADER(mspack.h, [],
- [AC_MSG_ERROR([mspack.h not found, install libmspack])], [])
- AC_CHECK_LIB(mspack, mspack_create_cab_decompressor, [],
- [AC_MSG_ERROR(libmspack not installed or functional)], [])
- else
- AC_MSG_RESULT([no])
- SYSTEM_MSPACK=NO
- fi
-fi
-AC_SUBST(SYSTEM_MSPACK)
-
-dnl ===================================================================
dnl Test whether to include MathMLDTD
dnl ===================================================================
AC_MSG_CHECKING([whether to include MathMLDTD])