summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 28f7fb021fca..eafb07b217df 100644
--- a/configure.in
+++ b/configure.in
@@ -56,8 +56,14 @@ add_warning()
if test "$have_WARNINGS" = "no" ; then
echo "*************************************" >> warn
have_WARNINGS="yes"
+ if test $(tput colors) -ge 8 ; then
+ dnl <esc> as actual byte (U+1b), [ escaped using quadrigraph @<:@
+ COLORWARN='*@<:@1;33;40m WARNING @<:@0m:'
+ else
+ COLORWARN="* WARNING :"
+ fi
fi
- echo "* WARNING : $@" >> warn
+ echo "$COLORWARN $@" >> warn
}
if test -n "$SOLARENV" ; then