summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in44
1 files changed, 22 insertions, 22 deletions
diff --git a/configure.in b/configure.in
index 8624333bf2e2..895d43be5451 100755
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
dnl configure.in serves as input for the GNU autoconf package
dnl in order to create a configure script.
-AC_INIT([LibreOffice], [3.3],,, [http://documentfoundation.org/])
+AC_INIT([LibreOffice], [3.4],,, [http://documentfoundation.org/])
AC_PREREQ(2.50)
echo "$@" >config.parms
@@ -472,6 +472,11 @@ AC_ARG_ENABLE(extra-font,
[Add extra font content.]),
,)
+AC_ARG_ENABLE(lomenubar,
+ AS_HELP_STRING([--enable-lomenubar],
+ [Enable global menu support.]),
+,)
+
dnl ===================================================================
dnl Optional Packages (--with/without-)
dnl ===================================================================
@@ -1176,15 +1181,6 @@ AC_ARG_WITH(lang,
],
,)
-AC_ARG_WITH(poor-help-localizations,
- AS_HELP_STRING([--with-poor-help-localizations],
- [Use this option to specify which languages have unusable help localizations.
- Separate multiple languages with space.])
- [
- Usage: --with-poor-help-localizations="af be"
- ],
-,)
-
AC_ARG_WITH(intro-bitmap,
[ --with-intro-bitmap Prefer the specified intro bitmap over the
the default one.
@@ -1212,7 +1208,7 @@ AC_ARG_WITH(install-dirname,
[Specify the directory name of the core LibO install dir. The final
installation path is defined by <libdir>/<install-dirname>.
The default value is "libreoffice" and the default installation
- patch is /usr/lib/libreoffice.
+ path is /usr/lib/libreoffice.
FIXME: It affects only the installation by "make install" and not the
generated installation sets.])
@@ -7449,6 +7445,19 @@ AC_SUBST(WITH_EXTRA_FONT)
AC_SUBST(OOOP_FONTS_PACK)
dnl ===================================================================
+dnl Test whether to build global menu support
+dnl ===================================================================
+AC_MSG_CHECKING([whether to build global menu support])
+if test "z$enable_lomenubar" = "z" -o "z$enable_lomenubar" = "zno" ; then
+ AC_MSG_RESULT([no])
+ ENABLE_LOMENUBAR="FALSE"
+else
+ AC_MSG_RESULT([yes])
+ ENABLE_LOMENUBAR="TRUE"
+fi
+AC_SUBST(ENABLE_LOMENUBAR)
+
+dnl ===================================================================
dnl Test whether to enable ActiveX embedding
dnl ===================================================================
if test "$_os" = "WINNT"; then
@@ -7758,14 +7767,14 @@ dnl ===================================================================
GIT_REPO_NAMES="artwork base calc components extensions extras filters help impress libs-core libs-extern libs-extern-sys libs-gui postprocess sdk testing ure writer"
AC_MSG_CHECKING([which languages to be built])
# get list of all languages
-# generate shell variable from completelangiso= from solenv/inc/postset.mk
+# generate shell variable from completelangiso= from solenv/inc/langlist.mk
# the sed command does the following:
# + if a line ends with a backslash, append the next line to it
# + adds " on the beginning of the value (after =)
# + adds " at the end of the value
# + removes en-US; we want to put it on the beginning
# + prints just the section starting with 'completelangiso=' and ending with the " at the end of line
-[eval $(sed -e :a -e '/\\$/N; s/\\\n//; ta' -n -e 's/=/="/;s/\([^\\]\)$/\1"/;s/en-US//;/^completelangiso/p' solenv/inc/postset.mk)]
+[eval $(sed -e :a -e '/\\$/N; s/\\\n//; ta' -n -e 's/=/="/;s/\([^\\]\)$/\1"/;s/en-US//;/^completelangiso/p' solenv/inc/langlist.mk)]
ALL_LANGS="en-US $completelangiso"
# check the configured localizations
WITH_LANG="$with_lang"
@@ -7788,15 +7797,6 @@ AC_SUBST(ALL_LANGS)
AC_SUBST(WITH_LANG)
AC_SUBST(GIT_REPO_NAMES)
-AC_MSG_CHECKING([which languages have poor help localizations])
-WITH_POOR_HELP_LOCALIZATIONS="$with_poor_help_localizations"
-if test -z "$WITH_POOR_HELP_LOCALIZATIONS"; then
- AC_MSG_RESULT([none])
-else
- AC_MSG_RESULT([$WITH_POOR_HELP_LOCALIZATIONS])
-fi
-AC_SUBST(WITH_POOR_HELP_LOCALIZATIONS)
-
AC_MSG_CHECKING([for another 'intro' bitmap])
INTRO_BITMAP=
if test -z "$with_intro_bitmap" -o "$with_intro_bitmap" = "no" ; then