summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in154
1 files changed, 12 insertions, 142 deletions
diff --git a/configure.in b/configure.in
index 17cc81f905f5..0ce538aeed8e 100644
--- a/configure.in
+++ b/configure.in
@@ -115,10 +115,6 @@ AC_ARG_ENABLE(qadevooo,
[ --disable-qadevooo OO.o includes some qa testsuites which some
packagers may wish to build without
],,enable_qadevooo="yes")
-AC_ARG_ENABLE(fontooo,
-[ --disable-fontooo disable FontOOo
- (useful for distributions using fontconfig for OOo)
-],,enable_fontooo="yes")
AC_ARG_ENABLE(mathmldtd,
[ --disable-mathmldtd disable mathmldtd
(useful for distributions that want to avoid packaging
@@ -131,9 +127,6 @@ AC_ARG_ENABLE(evolution2,
AC_ARG_WITH(system-stdlibs,
[ --with-system-stdlibs use libstdc++/libgcc_s already on system
],,checkforstdlibproblems=yes)
-AC_ARG_WITH(system-mspack,
-[ --with-system-mspack use libmspack already installed on system
-],,)
AC_ARG_ENABLE(cups,
[ --disable-cups disable cups support in the psprint project
],,enable_cups=yes)
@@ -786,12 +779,6 @@ AC_ARG_WITH(build-version,
Usage: --with-build-version="Built by Jim"
],with_build_version=$withval)
-AC_ARG_ENABLE(sgistl,
-[ --enable-sgistl for IRIX users, use this option option to build
- OpenOffice.org using SGI's STL.
-
- Usage: --enable-sgistl=yes
-],,)
AC_ARG_WITH(alloc,
[ --with-alloc Define which allocator to build with
(choices are oo, system, tcmalloc)
@@ -939,9 +926,6 @@ case "$build_os" in
test_cups=yes
test_randr=yes
test_freetype=yes
- if getconf GNU_LIBPTHREAD_VERSION |grep -q NPTL; then
- PTHREAD_CFLAGS="-DNPTL"
- fi
_os=Linux
;;
gnu)
@@ -1021,12 +1005,6 @@ case "$build_os" in
PTHREAD_LIBS="-pthread -lpthread"
_os=NetBSD
;;
- irix*)
- test_cups=no
- test_randr=no
- test_freetype=yes
- _os=IRIX
- ;;
aix*)
test_cups=no
test_randr=no
@@ -1635,31 +1613,6 @@ fi
AC_SUBST(HAVE_LD_HASH_STYLE)
dnl ===================================================================
-dnl Test the IRIX SGI Mips pro compiler
-dnl ===================================================================
-if test "$_os" = "IRIX" -o "$_os" = "IRIX64"; then
- if test "$CC" = "cc"; then
- AC_PATH_PROGS(_cc, cc)
- COMPATH=`echo $_cc | $SED -n "s/\/bin\/cc//p"`
- AC_MSG_CHECKING([the SGI MIPSpro C compiler version])
- dnl cc -version outputs to standard error!!!!
- _mipspro_version=`$CC -version 2>&1 | $AWK '{ print $4 }'`
- _mipspro_major=`echo $_mipspro_version | $AWK -F. '{ print $1 }'`
- if test "$_mipspro_major" != "7"; then
- AC_MSG_ERROR([found version "$_mipspro_version", use version 7.2+ of the SGI MIPSpro C compiler])
- else
- _mipspro_minor=`echo $_mipspro_version | $AWK -F. '{ if ($2 <= 1) print "false"; else print "true" }'`
- if test "$_mipspro_minor" = "false"; then
- AC_MSG_ERROR([found version "$_mipspro_version", use version 7.2+ of the SGI MIPSpro C compiler])
- else
- dnl compiler will do
- AC_MSG_RESULT([checked])
- fi
- fi
- fi
-fi
-
-dnl ===================================================================
dnl Test the Compaq compiler for OSF1
dnl ===================================================================
if test "$_os" = "OSF1"; then
@@ -2288,21 +2241,6 @@ if test "$_os" = "Darwin"; then
fi
fi
dnl ===================================================================
-dnl Extra checking for the IRIX compiler
-dnl ===================================================================
-if test "$_os" = "IRIX" -o "$_os" = "IRIX64"; then
- dnl MIPSpro C++ compiler packaged with MIPSpro C compiler
- if test "$CC" = "cc"; then
- AC_MSG_CHECKING([SGI MIPSpro C++ Compiler])
- if test "$CXX" != "CC"; then
- AC_MSG_WARN([SGI MIPSpro C++ was not found])
- echo "SGI MIPSpro C++ was not found" >> warn
- else
- AC_MSG_RESULT([checked])
- fi
- fi
-fi
-dnl ===================================================================
dnl Extra checking for the OSF compiler
dnl ===================================================================
if test "$_os" = "OSF1"; then
@@ -2444,23 +2382,6 @@ if test "$_os" = "SunOS"; then
fi
dnl ===================================================================
-dnl Checks for SGI STL
-dnl ===================================================================
-if test -n "$enable_sgistl" && "$enable_sgistl" != "no"; then
- if test "$_os" = "IRIX" -o "$_os" = "IRIX64"; then
- AC_MSG_CHECKING([for SGI STL])
- if test -d /usr/include/CC ; then
- AC_MSG_RESULT([yes.])
-
- else
- AC_MSG_RESULT([not found.])
- fi
- else
- AC_MSG_ERROR([Option --enable-sgistl is only valid for IRIX])
- fi
-else
-
-dnl ===================================================================
dnl Checks for what the default STL should be
dnl ===================================================================
AC_MSG_CHECKING([what the default STL should be])
@@ -2543,19 +2464,6 @@ dnl ===================================================================
else
AC_MSG_ERROR([STLport libraries not found])
fi
- elif test "$_os" = "IRIX" -o "$_os" = "IRIX64"; then
- if test -f "$STLPORT4/lib/libstlport_mipspro_41.so"; then
- AC_MSG_RESULT([checked])
- else
- if test -f "$STLPORT4/lib/libstlport_gcc.so"; then
- AC_MSG_RESULT([checked])
- elif test -f "$STLPORT4/lib/libstlport.so"; then
- AC_MSG_RESULT([checked])
- STLPORT_VER=500
- else
- AC_MSG_ERROR([STLport libraries not found])
- fi
- fi
else
if test -f "$STLPORT4/lib/libstlport_gcc.so"; then
AC_MSG_RESULT([checked])
@@ -2572,7 +2480,6 @@ dnl ===================================================================
echo "using stlport. Warning, breaks your ABI compatability!" >>warn
fi
fi
-fi
if test -z "$STLPORT4"; then
STLPORT4="NO_STLPORT4"
@@ -2713,11 +2620,18 @@ _ACEOF
if ! $CXX $CXXFLAGS $CPPFLAGS -fpic -S visibility.cxx 2>/dev/null > /dev/null; then
gccvisbroken=yes
else
- if $EGREP -q '@PLT|\$stub|\(PLT\)' visibility.s; then
- gccvisbroken=no;
- else
- gccvisbroken=yes;
- fi
+ case "$build_cpu" in
+ i?86|x86_64)
+ if $EGREP -q '@PLT' visibility.s; then
+ gccvisbroken=no
+ else
+ gccvisbroken=yes
+ fi
+ ;;
+ *)
+ gccvisbroken=no
+ ;;
+ esac
fi
rm -f visibility.s
@@ -3351,9 +3265,6 @@ if test "$_os" != "WINNT" -a \( "z$enable_epm" = "z" -o "$enable_epm" != "no" \)
OSF1)
PKGFORMAT=setld
;;
- IRIX)
- PKGFORMAT=tardist
- ;;
# we never should get here since we check the arciecture/os at the beginning,
# but go sure...
*)
@@ -6286,47 +6197,6 @@ fi
AC_SUBST(ENABLE_KAB)
dnl ===================================================================
-dnl Test whether to include FontOOo
-dnl ===================================================================
-AC_MSG_CHECKING([whether to include FontOOo])
-if test -n "$enable_fontooo"; then
- if test "$enable_fontooo" = "no"; then
- AC_MSG_RESULT([no])
- WITH_FONTOOO=NO
- SCPDEFS="$SCPDEFS -DWITHOUT_FONTOOO"
- else
- AC_MSG_RESULT([yes])
- WITH_FONTOOO=YES
- BUILD_TYPE="$BUILD_TYPE MSFONTEXTRACT"
- fi
-else
- AC_MSG_RESULT([no])
- WITH_FONTOOO=NO
- SCPDEFS="$SCPDEFS -DWITHOUT_FONTOOO"
-fi
-AC_SUBST(WITH_FONTOOO)
-
-if test "$WITH_FONTOOO" = "YES"; then
- dnl ===============================================================
- dnl Check whether to use libmspack from system
- dnl ===============================================================
- AC_MSG_CHECKING([whether to use system libmspack])
- if test -n "$with_system_mspack" -o -n "$with_system_libs" && \
- test "$with_system_mspack" != "no"; then
- AC_MSG_RESULT([yes])
- SYSTEM_MSPACK=YES
- AC_CHECK_HEADER(mspack.h, [],
- [AC_MSG_ERROR([mspack.h not found, install libmspack])], [])
- AC_CHECK_LIB(mspack, mspack_create_cab_decompressor, [],
- [AC_MSG_ERROR(libmspack not installed or functional)], [])
- else
- AC_MSG_RESULT([no])
- SYSTEM_MSPACK=NO
- fi
-fi
-AC_SUBST(SYSTEM_MSPACK)
-
-dnl ===================================================================
dnl Test whether to include MathMLDTD
dnl ===================================================================
AC_MSG_CHECKING([whether to include MathMLDTD])