summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in38
1 files changed, 34 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 3b27ac838781..cc251d2d3d59 100644
--- a/configure.in
+++ b/configure.in
@@ -384,7 +384,12 @@ AC_ARG_ENABLE(ext-barcode,
AC_ARG_ENABLE(database-connectivity,
AS_HELP_STRING([--disable-database-connectivity],
- [Disable various database connectivity. Work in progress, don't use.])
+ [Disable various database connectivity. Work in progress, use only if you are hacking on it.])
+)
+
+AC_ARG_ENABLE(interpreters,
+ AS_HELP_STRING([--disable-interpreters],
+ [Disable BASIC, Java and Python. Work in progress, use only if you are hacking on it.])
)
AC_ARG_ENABLE(ext-diagram,
@@ -2031,6 +2036,22 @@ else
fi
AC_SUBST(DISABLE_DBCONNECTIVITY)
+if test -z "$enable_interpreters"; then
+ # Disable interpreters for iOS unless specifically overridden
+ # with --enable-interpreters.
+ if test $_os != iOS; then
+ enable_interpreters=yes
+ fi
+fi
+
+DISABLE_INTERPRETERS=''
+if test "$enable_interpreters" = yes; then
+ BUILD_TYPE="$BUILD_TYPE INTERPRETERS"
+else
+ DISABLE_INTERPRETERS='TRUE'
+fi
+AC_SUBST(DISABLE_INTERPRETERS)
+
dnl ===================================================================
dnl Extra check for Windows. Cygwin builds need gcc to build dmake
dnl although MSVC is used to build other build-time tools and
@@ -4508,8 +4529,13 @@ dnl Java support enable
dnl ===================================================================
AC_MSG_CHECKING([whether to build with Java support])
if test "$with_java" != "no"; then
- AC_MSG_RESULT([yes])
- SOLAR_JAVA="TRUE"
+ if test "$DISABLE_INTERPRETERS" = TRUE; then
+ AC_MSG_RESULT([no, overridden by --disable-interpreters])
+ SOLAR_JAVA=""
+ else
+ AC_MSG_RESULT([yes])
+ SOLAR_JAVA="TRUE"
+ fi
else
AC_MSG_RESULT([no])
SOLAR_JAVA=""
@@ -5921,7 +5947,11 @@ no|disable)
DISABLE_PYTHON=TRUE
;;
""|yes|auto)
- if test $build_os = cygwin; then
+ if test "$DISABLE_INTERPRETERS" = TRUE; then
+ AC_MSG_RESULT([no, overridden by --disable-interpreters])
+ enable_python=no
+ DISABLE_PYTHON=TRUE
+ elif test $build_os = cygwin; then
dnl When building on Windows we don't attempt to use any installed
dnl "system" Python.
dnl