summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e46776bb2ad0..cc9a533e5553 100644
--- a/configure.in
+++ b/configure.in
@@ -61,6 +61,9 @@ AC_ARG_WITH(vba-package-format,
AC_ARG_ENABLE(pch,
[ --enable-pch EXPERIMENTAL: Enables precompiled header support for C++.
],,)
+AC_ARG_ENABLE(hids,
+[ --enable-hids Enables generation of HelpId lists.
+],,)
AC_ARG_ENABLE(mozilla,
[ --disable-mozilla OO.o usually includes a strangely hacked up mozilla
binary for your platform, to build without this
@@ -1492,6 +1495,19 @@ fi
AC_SUBST(ENABLE_PCH)
dnl ===================================================================
+dnl Set the NO_HIDS variable. (enable with --enable-hids)
+dnl ===================================================================
+AC_MSG_CHECKING([whether to enable hid list feature])
+if test -n "$enable_hids" && test "$enable_hids" != "no"; then
+ NO_HIDS=""
+ AC_MSG_RESULT([yes])
+else
+ NO_HIDS="TRUE"
+ AC_MSG_RESULT([no])
+fi
+AC_SUBST(NO_HIDS)
+
+dnl ===================================================================
dnl Search all the common names for GNU make
dnl ===================================================================
AC_MSG_CHECKING([for GNU make])