summaryrefslogtreecommitdiff
path: root/framework/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'framework/meson.build')
-rw-r--r--framework/meson.build200
1 files changed, 56 insertions, 144 deletions
diff --git a/framework/meson.build b/framework/meson.build
index 92dc4097eec2..3ff9fa9f5f2b 100644
--- a/framework/meson.build
+++ b/framework/meson.build
@@ -1,144 +1,3 @@
-fwi_lib = shared_library('fwilo',
- 'source/fwi/classes/converter.cxx',
- 'source/fwi/classes/protocolhandlercache.cxx',
- 'source/fwi/helper/mischelper.cxx',
- 'source/fwi/helper/shareablemutex.cxx',
- 'source/fwi/jobs/configaccess.cxx',
- 'source/fwi/jobs/jobconst.cxx',
- 'source/fwi/threadhelp/transactionmanager.cxx',
- 'source/fwi/uielement/constitemcontainer.cxx',
- 'source/fwi/uielement/itemcontainer.cxx',
- 'source/fwi/uielement/rootitemcontainer.cxx',
- udk_fake_h, off_fake_h,
- cpp_args: ['-DFWI_DLLIMPLEMENTATION',
- '-DLIBO_INTERNAL_ONLY'],
- include_directories: [main_inc, udkh_inc, offapi_inc, 'source/inc', 'inc'],
- link_with: [
- comphelper_lib,
- cppu_lib,
- cppuhelper_lib,
- i18nlangtag_lib,
- sal_lib,
- salhelper_lib,
- svl_lib,
- svt_lib,
- tl_lib,
- utl_lib,
- vcl_lib,
- ],
- install: true,
-)
-
-fwe_lib = shared_library('fwelo',
- 'source/fwe/classes/actiontriggercontainer.cxx',
- 'source/fwe/classes/actiontriggerpropertyset.cxx',
- 'source/fwe/classes/actiontriggerseparatorpropertyset.cxx',
- 'source/fwe/classes/addonmenu.cxx',
- 'source/fwe/classes/addonsoptions.cxx',
- 'source/fwe/classes/framelistanalyzer.cxx',
- 'source/fwe/classes/fwkresid.cxx',
- 'source/fwe/classes/imagewrapper.cxx',
- 'source/fwe/classes/rootactiontriggercontainer.cxx',
- 'source/fwe/classes/sfxhelperfunctions.cxx',
- 'source/fwe/dispatch/interaction.cxx',
- 'source/fwe/helper/actiontriggerhelper.cxx',
- 'source/fwe/helper/configimporter.cxx',
- 'source/fwe/helper/propertysetcontainer.cxx',
- 'source/fwe/helper/titlehelper.cxx',
- 'source/fwe/helper/documentundoguard.cxx',
- 'source/fwe/helper/undomanagerhelper.cxx',
- 'source/fwe/xml/menuconfiguration.cxx',
- 'source/fwe/xml/menudocumenthandler.cxx',
- 'source/fwe/xml/saxnamespacefilter.cxx',
- 'source/fwe/xml/statusbarconfiguration.cxx',
- 'source/fwe/xml/statusbardocumenthandler.cxx',
- 'source/fwe/xml/toolboxconfiguration.cxx',
- 'source/fwe/xml/toolboxdocumenthandler.cxx',
- 'source/fwe/xml/xmlnamespaces.cxx',
- 'source/services/dispatchhelper.cxx',
- udk_fake_h, off_fake_h,
- cpp_args: ['-DFWE_DLLIMPLEMENTATION',
- '-DLIBO_INTERNAL_ONLY'],
- include_directories: [main_inc, udkh_inc, offapi_inc, 'source/inc', 'inc'],
- link_with: [
- comphelper_lib,
- cppu_lib,
- cppuhelper_lib,
- fwi_lib,
- sal_lib,
- salhelper_lib,
- svl_lib,
- svt_lib,
- tl_lib,
- utl_lib,
- vcl_lib,
- ],
- install: true,
-)
-
-fwl_lib = shared_library('fwllo',
- 'source/dispatch/mailtodispatcher.cxx',
- 'source/dispatch/oxt_handler.cxx',
- 'source/dispatch/popupmenudispatcher.cxx',
- 'source/dispatch/servicehandler.cxx',
- 'source/recording/dispatchrecorder.cxx',
- 'source/recording/dispatchrecordersupplier.cxx',
- 'source/register/registertemp.cxx',
- 'source/dispatch/dispatchdisabler.cxx',
- 'source/services/mediatypedetectionhelper.cxx',
- 'source/services/uriabbreviation.cxx',
- 'source/uielement/fontmenucontroller.cxx',
- 'source/uielement/fontsizemenucontroller.cxx',
- 'source/uielement/footermenucontroller.cxx',
- 'source/uielement/headermenucontroller.cxx',
- 'source/uielement/langselectionmenucontroller.cxx',
- 'source/uielement/macrosmenucontroller.cxx',
- 'source/uielement/newmenucontroller.cxx',
- 'source/uielement/toolbarmodemenucontroller.cxx',
- 'source/uielement/toolbarsmenucontroller.cxx',
- udk_fake_h, off_fake_h, common_hxx,
- cpp_args: ['-DFWL_DLLIMPLEMENTATION',
- '-DLIBO_INTERNAL_ONLY'],
- include_directories: [main_inc, udkh_inc, offapi_inc, 'source/inc', 'inc', setup_inc],
- link_with: [
- comphelper_lib,
- cppu_lib,
- cppuhelper_lib,
- fwe_lib,
- fwi_lib,
- i18nlangtag_lib,
- sal_lib,
- svl_lib,
- svt_lib,
- svt_lib,
- tk_lib,
- tl_lib,
- utl_lib,
- vcl_lib,
- ],
- install: true,
-)
-
-fwm_lib = shared_library('fwmlo',
- 'source/dispatch/systemexec.cxx',
- 'source/jobs/helponstartup.cxx',
- 'source/jobs/shelljob.cxx',
- 'source/register/register3rdcomponents.cxx',
- udk_fake_h, off_fake_h, common_hxx,
- cpp_args: ['-DFWM_DLLIMPLEMENTATION',
- '-DLIBO_INTERNAL_ONLY'],
- include_directories: [main_inc, udkh_inc, offapi_inc, 'source/inc', 'inc', setup_inc],
- link_with: [
- comphelper_lib,
- fwi_lib,
- cppuhelper_lib,
- cppu_lib,
- vcl_lib,
- sal_lib,
- ],
- install: true,
-)
-
fwk_lib = shared_library('fwklo',
'source/accelerators/acceleratorcache.cxx',
'source/accelerators/acceleratorconfiguration.cxx',
@@ -205,7 +64,6 @@ fwk_lib = shared_library('fwklo',
'source/uiconfiguration/uicategorydescription.cxx',
'source/uiconfiguration/uiconfigurationmanager.cxx',
'source/uiconfiguration/windowstateconfiguration.cxx',
- 'source/uielement/addonstoolbarmanager.cxx',
'source/uielement/addonstoolbarwrapper.cxx',
'source/uielement/buttontoolbarcontroller.cxx',
'source/uielement/comboboxtoolbarcontroller.cxx',
@@ -254,6 +112,62 @@ fwk_lib = shared_library('fwklo',
'source/xml/acceleratorconfigurationwriter.cxx',
'source/xml/imagesconfiguration.cxx',
'source/xml/imagesdocumenthandler.cxx',
+ 'source/dispatch/systemexec.cxx',
+ 'source/jobs/helponstartup.cxx',
+ 'source/jobs/shelljob.cxx',
+ 'source/dispatch/mailtodispatcher.cxx',
+ 'source/dispatch/oxt_handler.cxx',
+ 'source/dispatch/popupmenudispatcher.cxx',
+ 'source/dispatch/servicehandler.cxx',
+ 'source/recording/dispatchrecorder.cxx',
+ 'source/recording/dispatchrecordersupplier.cxx',
+ 'source/dispatch/dispatchdisabler.cxx',
+ 'source/services/mediatypedetectionhelper.cxx',
+ 'source/services/uriabbreviation.cxx',
+ 'source/uielement/fontmenucontroller.cxx',
+ 'source/uielement/fontsizemenucontroller.cxx',
+ 'source/uielement/footermenucontroller.cxx',
+ 'source/uielement/headermenucontroller.cxx',
+ 'source/uielement/langselectionmenucontroller.cxx',
+ 'source/uielement/macrosmenucontroller.cxx',
+ 'source/uielement/newmenucontroller.cxx',
+ 'source/uielement/toolbarmodemenucontroller.cxx',
+ 'source/uielement/toolbarsmenucontroller.cxx',
+ 'source/fwi/classes/converter.cxx',
+ 'source/fwi/classes/protocolhandlercache.cxx',
+ 'source/fwi/helper/mischelper.cxx',
+ 'source/fwi/helper/shareablemutex.cxx',
+ 'source/fwi/jobs/configaccess.cxx',
+ 'source/fwi/threadhelp/transactionmanager.cxx',
+ 'source/fwi/uielement/constitemcontainer.cxx',
+ 'source/fwi/uielement/itemcontainer.cxx',
+ 'source/fwi/uielement/rootitemcontainer.cxx',
+ 'source/fwe/classes/actiontriggercontainer.cxx',
+ 'source/fwe/classes/actiontriggerpropertyset.cxx',
+ 'source/fwe/classes/actiontriggerseparatorpropertyset.cxx',
+ 'source/fwe/classes/addonmenu.cxx',
+ 'source/fwe/classes/addonsoptions.cxx',
+ 'source/fwe/classes/framelistanalyzer.cxx',
+ 'source/fwe/classes/fwkresid.cxx',
+ 'source/fwe/classes/imagewrapper.cxx',
+ 'source/fwe/classes/rootactiontriggercontainer.cxx',
+ 'source/fwe/classes/sfxhelperfunctions.cxx',
+ 'source/fwe/dispatch/interaction.cxx',
+ 'source/fwe/helper/actiontriggerhelper.cxx',
+ 'source/fwe/helper/configimporter.cxx',
+ 'source/fwe/helper/propertysetcontainer.cxx',
+ 'source/fwe/helper/titlehelper.cxx',
+ 'source/fwe/helper/documentundoguard.cxx',
+ 'source/fwe/helper/undomanagerhelper.cxx',
+ 'source/fwe/xml/menuconfiguration.cxx',
+ 'source/fwe/xml/menudocumenthandler.cxx',
+ 'source/fwe/xml/saxnamespacefilter.cxx',
+ 'source/fwe/xml/statusbarconfiguration.cxx',
+ 'source/fwe/xml/statusbardocumenthandler.cxx',
+ 'source/fwe/xml/toolboxconfiguration.cxx',
+ 'source/fwe/xml/toolboxdocumenthandler.cxx',
+ 'source/fwe/xml/xmlnamespaces.cxx',
+ 'source/services/dispatchhelper.cxx',
udk_fake_h, off_fake_h, common_hxx, paths_hxx,
cpp_args: ['-DFWK_DLLIMPLEMENTATION',
'-DLIBO_INTERNAL_ONLY'],
@@ -262,8 +176,6 @@ fwk_lib = shared_library('fwklo',
comphelper_lib,
cppu_lib,
cppuhelper_lib,
- fwe_lib,
- fwi_lib,
i18nlangtag_lib,
sal_lib,
salhelper_lib,