summaryrefslogtreecommitdiff
path: root/udkapi/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'udkapi/meson.build')
-rw-r--r--udkapi/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/udkapi/meson.build b/udkapi/meson.build
index 17ec4b3c88b5..87ed016dd0b6 100644
--- a/udkapi/meson.build
+++ b/udkapi/meson.build
@@ -9,6 +9,20 @@ udkapi_rdb = custom_target('udkapi_rdb',
'@PRIVATE_DIR@',
'@OUTPUT@'])
+# udkapi.rdb seems to be installed as types.rdb.
+# Dunno why. The simplest thing here is to just gen it again.
+custom_target('types_rdb',
+ output: 'types.rdb',
+ command: [urbcompiler,
+ unoidl_write_exe,
+ meson.current_source_dir(),
+ '@PRIVATE_DIR@',
+ '@OUTPUT@'],
+ install: true,
+ install_dir: get_option('bindir')
+)
+
+
# FIXME, this only generates headers. There is no
# proper dependency tracking or dealing of the rdb file.
udk_fake_h = custom_target('udkapi_h',