From 69e14b0fee1c474168d8159b874d7c2fd9dea64f Mon Sep 17 00:00:00 2001
From: Markus Mohrhard <markus.mohrhard@collabora.co.uk>
Date: Mon, 3 Mar 2014 10:49:37 +0100
Subject: add experimental export file validation

In calc unit tests we validate the exported OOXML files now with
officeotron.

For this there must be a script called officeotron that takes the file
path.

Currently the generated files are still invalid but I'm going to fix it.

Change-Id: I1809b9457a535dbbe6a72f3778dfb53db168bbda
---
 configure.ac | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

(limited to 'configure.ac')

diff --git a/configure.ac b/configure.ac
index 4d980716d9ae..bf2d03c046ad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1835,6 +1835,15 @@ AC_ARG_WITH(ant-home,
     ],
 ,)
 
+AC_ARG_WITH(export-validation,
+    AS_HELP_STRING([--with-export-validation],
+        [If you want the exported files to be validated. Right now limited to OOXML files in calc export tests.
+         Note: You need an executable script officeotron that takes the path to the file.])
+    [
+                            Usage: --with-export-validation
+    ],
+,)
+
 AC_ARG_WITH(junit,
     AS_HELP_STRING([--with-junit],
         [Specifies the JUnit 4 jar file to use for JUnit-based tests.
@@ -2557,6 +2566,17 @@ dnl ENABLE_JAVA="TRUE" if we want there to be *run-time* (and build-time) suppor
 
 dnl ENABLE_JAVA="" indicate no Java support at all
 
+dnl ===================================================================
+dnl Export file validation
+dnl ===================================================================
+AC_MSG_CHECKING([whether to enable export file validation])
+if test "with_export_validation" != "no"; then
+    AC_MSG_RESULT([yes])
+    AC_DEFINE(HAVE_EXPORT_VALIDATION)
+else
+    AC_MSG_RESULT([no])
+fi
+
 dnl ===================================================================
 dnl  Test the Solaris compiler version
 dnl ===================================================================
-- 
cgit